Показано с 1 по 10 из 10

Тема: странный CX75

  1. #1
    Member
    Регистрация
    06.03.2004
    Адрес
    Нижегородская обл.
    Сообщений
    200
    Спасибо
    5
    Благодарностей: 2 : 2

    странный CX75

    Привет!
    Вот ведь аппаратик, всю голову уже сломал!
    Отдали в ремонт мол дисплей не работает, вода дескать попадала. Симптомы такие - при включении загорается белым дисплей, только мелькает изображение - тело вырубается. Ну, раз вода, открываю - в районе джойстика и обвязки ММС-коннектора действительно следы окиси, но очень мало. Также немного окиси около контактов АКБ. Вычистил, пропаял проц, диалог, дисплейный разъем и всю мелочь около него. Вот какя хрень - дисплей снимаешь, тело включается, слышно нажатие кнопок, мелодии вкл./выкл., вобщем все путем. Ставишь дисплей - при включении белый дисплей и рубится, гад.
    В сервис-моду без дисплея входит, информация, считанная папуа-утилитой, почти вся корректная, кроме
    Напряжение аккумулятора 5604 мВ!
    Неверная настройка аккумулятора!!!
    Цепочка Vbat (делитель R1022/R1023) проверен (220к и 330к), фулл пробовал проливать - пока без результата. После проливки фула, когда ситуация не изменилась, понятно, что дело в железе.
    Кто сталкивался с таким, подскажите, где копнуть?

    С ув, Александр.

    Да, дисплей подкидывал новый, диалог менял, проц -нет.

  2. #2
    Member
    Регистрация
    10.02.2005
    Сообщений
    361
    Спасибо
    0
    Благодарностей: 4 : 4
    Помой еще. Возможно средняя точка резисторного делителя, где-то подтекает на +. Смотри на обратной стороне дисплея, нет ли окислов.

  3. #3
    Member
    Регистрация
    06.03.2004
    Адрес
    Нижегородская обл.
    Сообщений
    200
    Спасибо
    5
    Благодарностей: 2 : 2
    Привет!
    Да весь он, блин, перемытый и тщательно пропаянный. Ведь парился с такой же проблемой, только с телом х65-серии (но разницы-то нет, схемы почти близнецы в части питания), кто-то с полгода назад, я копал, но тему эту так и не нашел, чем все закончилось. Может, кто-нить еще откликнится!

    С ув, Александр.

  4. #4
    Member
    Регистрация
    10.02.2005
    Сообщений
    361
    Спасибо
    0
    Благодарностей: 4 : 4
    Цитата Сообщение от alex6777
    Привет!
    Да весь он, блин, перемытый и тщательно пропаянный. Ведь парился с такой же проблемой, только с телом х65-серии (но разницы-то нет, схемы почти близнецы в части питания), кто-то с полгода назад, я копал, но тему эту так и не нашел, чем все закончилось. Может, кто-нить еще откликнится!

    С ув, Александр.
    Здравствуйте, Александр! Если Вы уверены в чистоте своего телефона на 100%, а это значит Вы его промыли в УЗ ванне и под чипами точно нет окислов. Причина завышения показания напряжение АКБ может крыться только в цепи R1023, R1022. Это линия сенсора АКБ, где с делителя на резисторах напряжение идет на вывод АЦП процессора. Где и происходит "оцифровка" и проверка с константами из Eeprom. Т.к. Вы их прозвонили и уверены в их исправности, то остается одна железная причина, по которой могут быть измененные показания. Ее я указал в предыдущем посте. Проверить точность работы этой линии можно, сделав замер напряжения в точке соединения этих резисторов. Напряжение Вы можете вычислить по формуле Uакб/Usens=(R1022+R1023)/R1023 от сюда Usens=Uакб/((R1022+R1023)/R1023). При точных номиналах резисторов и напряжении АКБ 4,2В, напряжение в точке делителя должно быть 1,68В. Замерять можно только калиброванным осцилографом или цифровым вольтметром (мультиметром) с высоким входным сопротивлением (не менее 1 МОм). Если все ОК (по формуле) и отклонения очень малы, то можно утверждать, что завышение показаний есть сбой в калибровках АКБ в Eeprom. Это уже софт. Но если софт в норме, а показания в вашем случае 5,604В, то напряжение в точке сенсора должно быть равно 2,02В (или около того), тогда еще раз смотрите железо на предмет окислов или утечек.

    Насчет дисплея могу только догадываться. Замените дисплей и проверьте работу с другим. Возможно причиной отключки является завышенное потребление тока, скажем при работе подсветки (узел подсветки). Или окислы на обратной поверхности дисплея между контактами или на навесных деталях. Если телефон утоплен недавно, проверте наличие влаги под подложкой дисплея, возможно он не просох полностью, что и является причиной повышенного потребления.

    Смотрите, проверяйте, удачи!

    PS. Не проводите аналогии, что кто-то и где-то. Возможно в вашем случае все гораздо проще.

  5. Спасибо сказали:

    Awwar (09.10.2009)

  6. #5
    Member
    Регистрация
    06.03.2004
    Адрес
    Нижегородская обл.
    Сообщений
    200
    Спасибо
    5
    Благодарностей: 2 : 2
    Привет!
    С утверждением
    "Причина завышения показания напряжение АКБ может крыться только в цепи R1023, R1022. Это линия сенсора АКБ, где с делителя на резисторах напряжение идет на вывод АЦП процессора."
    не могу согласиться полностью, поскольку для правильной работы АЦП необходимо еще и опорное напряжение. В общей точке делителя R1022 и R1023 намерил цифровым мултиметром 1.37В (на батарее 3.75В + входное сопротивление прибора = норма). А вот что служит опорным. Должно быть VREF, но у меня в TP1021 (VREF) 0.0В (ноль, вобщем). Померил VREF на CX65, там тоже ноль.
    Проц пробую менять, короче.

    С ув, Александр.

  7. #6
    Member
    Регистрация
    10.02.2005
    Сообщений
    361
    Спасибо
    0
    Благодарностей: 4 : 4
    Не могу не согласиться, что для АЦП требуется опорное напряжение. К сожалению мануала на ЦП нет. Но тогда сигнал VREF, если принять его за опорное, должен быть в виде пилы и вполне вероятно присутствует в виде одиночных циклов с большим(относительно) периодом повторения, поэтому их трудно "засечь" мультиметром. Тогда IREF = это ток интегрирующей цепи, а VREF - напряжение. Хотя это мои догадки, построенные на принципах измерения постоянного напряжения. Вряд ли замена проца поможет, он же производит замеры, хоть и с ошбкой. Это скорее всего софтовые калибровки съехали.

    PS Если все-таки это формирователь пилы, то изменеия времени интегратора в большую сторону, приведет к увеличению показаний. Если резючек увеличен, то ток уменьшен, а значит время заряда кондюка больше, отсюда и показания больше. Проверьте. Успехов.

  8. #7
    Member
    Регистрация
    06.03.2004
    Адрес
    Нижегородская обл.
    Сообщений
    200
    Спасибо
    5
    Благодарностей: 2 : 2
    Привет!
    Проблема с неверной настройкой АКБ решилась все-таки заменой проца. Проблема с вырубанием телефона при установленном дисплее не ушла! Причем дисплеев 2 - тот, который стоял + новенький, из упаковочки. Выяснил, что проблема по шине 2.9В (7 пин на гребенке дисплея). По ней и так занижены показатели при прозвонке тестером, а как, похоже, добавляется потребление на дисплей, срабатывает защита. Найти гада, который садит, не получается. Заменить EPSONы нечем, но их снимал, шина все равно оставалась подкороченная.Диалог менялся, проц тоже, эпсоны снимал - что еще? Да, скорее всего коротит какая-нить емкостюшка подмоченная. Буду искать...

    С ув, Александр.

  9. #8
    Member
    Регистрация
    10.02.2005
    Сообщений
    361
    Спасибо
    0
    Благодарностей: 4 : 4
    Раз уж мы так тщательно рассмотрели цепи изм. АКБ, хотелось бы узнать (для общего развития), как обстоят дела с сигналами VREF и IREF на новом проце. Что касаемо 2,9В - их используют проц, дисплей и аудио (D3300).

  10. #9
    Member
    Регистрация
    03.11.2006
    Адрес
    ярославль
    Сообщений
    328
    Спасибо
    47
    Благодарностей: 11 : 7
    у меня щас такая же фигня -с дисплеем выключается предварительно моргая белым дисплеем-и всё...без него работает всё и звонит -и чо хочешь -в воде была тока обвязка но грешу на диалог...в папуасе кажет напругу на батарее нормальную 4.2 -при заряж. батарее

  11. #10
    Member
    Регистрация
    03.11.2006
    Адрес
    ярославль
    Сообщений
    328
    Спасибо
    47
    Благодарностей: 11 : 7
    у меня щас такая же фигня -с дисплеем выключается предварительно моргая белым дисплеем-и всё...без него работает всё и звонит -и чо хочешь -в воде была тока обвязка у коннектора дисплея-всю заменил с донора но грешу на диалог...в папуасе кажет напругу на батарее нормальную 4.2 -при заряж. батарее

Похожие темы

  1. CX75
    от Ашот Мурадян в разделе BENQ-Siemens для новичков
    Ответов: 2
    Последний ответ: 07.04.2009, 04:36
  2. cx75
    от zema190484 в разделе BENQ-Siemens для новичков
    Ответов: 4
    Последний ответ: 15.11.2006, 11:18
  3. CX75
    от valera_198224 в разделе BENQ-Siemens для новичков
    Ответов: 7
    Последний ответ: 01.03.2006, 21:42
  4. cx75
    от sotovic в разделе SGold 8870/8875
    Ответов: 8
    Последний ответ: 21.01.2006, 04:03
  5. CX75 v5
    от Vladim в разделе SGold 8870/8875
    Ответов: 5
    Последний ответ: 08.09.2005, 11:25

Социальные закладки

Социальные закладки

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •  
  Рейтинг@Mail.ru